4OD and VMWare 2

This is a post about how I fixed a broken 4OD service after upgrading from VMWare Fusion 1 to 2. I’m not sure if it was the VMWare upgrade, or just some other variable in the 4OD service changing at the same time as I chose to upgrade. Regardless, videos would play, but the video would be completely garbled. This was rather distressing as Rose and I often enjoy an episode of Black Books and the like.

As a note of protest, I wish 4OD were not a Windows only application— it’s tied to Windows Media Player —but it is, so VMWare or an equivalent solution is the best way to use it. The BBC’s iPlayer works excellently on many operating systems, so why Channel 4 couldn’t use Flash for free programs at least is irritating.

Anyway, back to my issue. Google didn’t seem to offer any answers for the obvious combinations of “VMWare” and “4OD”. I tried several tweaks to VMWare, turning of video acceleration in VMWare and testing in both full screen and windowed mode. None of these worked, to my dismay.

Finally I inspected my Windows installation a little more. I hadn’t looked at this originally, as it hadn’t changed during the upgrade. I saw that I had an old version of Windows Media Player, version 10. 4OD states version 10 is supported, but I found that upgrading to version 11 fixed my problem.

So the solution: keep your Windows Media Player up to date.

Was it VMWare’s fault? Or did an update to 4OD undergo way too little testing before release? I don’t know, but at least it stumbles along for now and I can watch my little shows.

.:.